summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorGustaf Rydholm <gustaf.rydholm@gmail.com>2021-05-02 13:51:15 +0200
committerGustaf Rydholm <gustaf.rydholm@gmail.com>2021-05-02 13:51:15 +0200
commit1d0977585f01c42e9f6280559a1a98037907a62e (patch)
tree7e86dd71b163f3138ed2658cb52c44e805f21539 /pyproject.toml
parent58ae7154aa945cfe5a46592cc1dfb28f0a4e51b3 (diff)
Implemented training script with hydra
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f9bce95..6f050c9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -32,7 +32,7 @@ nltk = "^3.5"
torch-summary = "^1.4.2"
defusedxml = "^0.6.0"
omegaconf = "^2.0.2"
-wandb = "^0.10.27"
+wandb = "^0.10.28"
einops = "^0.3.0"
gtn = "^0.0.0"
sentencepiece = "^0.1.95"
@@ -41,6 +41,7 @@ Pillow = "^8.1.2"
madgrad = "^1.0"
editdistance = "^0.5.3"
torchmetrics = "^0.2.0"
+hydra-core = "^1.0.6"
[tool.poetry.dev-dependencies]
pytest = "^5.4.2"