summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authoraktersnurra <grydholm@kth.se>2020-05-30 19:23:48 +0200
committeraktersnurra <grydholm@kth.se>2020-05-30 19:23:48 +0200
commit81d48b6a4da96696afde87a54f9fb7d89dd64cd2 (patch)
tree081f5d051833f081c407f637a74fe32ebacb8ce7 /pyproject.toml
parent314193335ef465bdb58ba44d14f2e082a3f1a8d0 (diff)
inital commit.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e59b4cf
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,21 @@
+[tool.poetry]
+name = "text-recognizer"
+version = "0.1.0"
+authors = ["aktersnurra <gustaf.rydholm@gmail.com>"]
+description = "A text recognizer using best pratices in python and deep learning."
+license = "MIT"
+readme = "README.md"
+homepage = "https://github.com/aktersnurra/text-recognizer"
+repository = "https://github.com/aktersnurra/text-recognizer"
+keywords = ["text recognizer, deep learning, pytorch"]
+
+[tool.poetry.dependencies]
+python = "^3.7"
+click = "^7.1.2"
+wandb = "^0.8.36"
+
+[tool.poetry.dev-dependencies]
+
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.masonry.api"