summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 64ae18b..89cc761 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -14,7 +14,7 @@ python = "^3.9"
loguru = "^0.6.0"
omegaconf = "^2.1.0"
einops = "^0.3.0"
-pytorch-lightning = "^1.7.5"
+pytorch-lightning = "^1.7.6"
hydra-core = "^1.1.1"
smart-open = "^5.2.1"
torch = "^1.11.0"
@@ -22,7 +22,7 @@ torchvision = "^0.12.0"
adan-pytorch = "^0.1.0"
torchmetrics = "^0.9.3"
-[tool.poetry.dev-dependencies]
+[tool.poetry.group.dev.dependencies]
pytest = "^5.4.2"
coverage = { extras = ["toml"], version = "^5.1" }
pytest-cov = "^2.9.0"
@@ -31,7 +31,7 @@ flake8 = "^5.0.4"
safety = "^1.9.0"
mypy = "^0.770"
typeguard = "^2.7.1"
-wandb = "^0.12.16"
+wandb = "0.12.16"
scipy = "^1.6.1"
jupyterlab = "^3.0.15"
ipywidgets = "^7.6.3"