summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..d3ea39d
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,18 @@
+[tool.poetry]
+name = "jax-optimization-tutorial"
+version = "0.1.0"
+description = ""
+authors = ["Gustaf Rydholm <gustaf.rydholm@gmail.com>"]
+
+[tool.poetry.dependencies]
+python = "^3.9"
+jax = "^0.3.4"
+jupyter = "^1.0.0"
+jaxlib = "^0.3.2"
+
+[tool.poetry.dev-dependencies]
+pytest = "^5.2"
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"