summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorGustaf Rydholm <gustaf.rydholm@gmail.com>2022-09-14 00:54:13 +0200
committerGustaf Rydholm <gustaf.rydholm@gmail.com>2022-09-14 00:54:13 +0200
commit026514d6565cbb3f96afd7f308cc4f22d3f7e88a (patch)
tree9251cfc41ea86393efadd36d6c73ee3a245772bc /pyproject.toml
parente06a94f0df3c19ecd23024162b3697bd1e12c8a9 (diff)
Update dependencies
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 13 insertions, 10 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 822fca9..64ae18b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -27,20 +27,12 @@ pytest = "^5.4.2"
coverage = { extras = ["toml"], version = "^5.1" }
pytest-cov = "^2.9.0"
pytest-mock = "^3.1.0"
-black = "^19.10b0"
-flake8 = "^3.8.2"
-flake8-bandit = "^2.1.2"
-flake8-black = "^0.2.0"
-flake8-bugbear = "^20.1.4"
-flake8-import-order = "^0.18.1"
+flake8 = "^5.0.4"
safety = "^1.9.0"
mypy = "^0.770"
typeguard = "^2.7.1"
wandb = "^0.12.16"
scipy = "^1.6.1"
-flake8-annotations = "^2.6.2"
-flake8-docstrings = "^1.6.0"
-darglint = "^1.8.0"
jupyterlab = "^3.0.15"
ipywidgets = "^7.6.3"
torchinfo = "^1.5.3"
@@ -57,11 +49,22 @@ tqdm = "^4.46.1"
toml = "^0.10.1"
setuptools = "59.5.0"
opencv-python = "^4.5.5"
-click = "^7.1.2"
+black = "^22.8.0"
+click = "^8.1.3"
+flake8-annotations = "^2.9.1"
+flake8-black = "^0.3.3"
+flake8-bugbear = "^22.9.11"
+flake8-docstrings = "^1.6.0"
+flake8-import-order = "^0.18.1"
+flake8-bandit = "^4.1.1"
+darglint = "^1.8.1"
[tool.coverage.report]
fail_under = 50
+[tool.isort]
+profile = "black"
+
[tool.poetry.scripts]
download-emnist = "text_recognizer.data.emnist:download_emnist"
download-nltk = "text_recognizer.data.utils.sentence_generator:load_nltk_brown_corpus"