summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authoraktersnurra <gustaf.rydholm@gmail.com>2020-06-02 22:49:22 +0200
committeraktersnurra <gustaf.rydholm@gmail.com>2020-06-02 22:49:22 +0200
commit118c02c2730aaac2d10c2b9847339f6ffc83223f (patch)
treef7e1dc9a7159b63945a19d742a525f20c90c969e /pyproject.toml
parent81d48b6a4da96696afde87a54f9fb7d89dd64cd2 (diff)
Working on lab 1.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e59b4cf..f8cd8b4 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -13,9 +13,40 @@ keywords = ["text recognizer, deep learning, pytorch"]
python = "^3.7"
click = "^7.1.2"
wandb = "^0.8.36"
+flake8-annotations = "^2.1.0"
+flake8-docstrings = "^1.5.0"
+darglint = "^1.3.1"
+desert = "^2020.1.6"
+marshmallow = "^3.6.0"
+sphinx-autodoc-typehints = "^1.10.3"
+sphinx_rtd_theme = "^0.4.3"
+boltons = "^20.1.0"
+h5py = "^2.10.0"
+toml = "^0.10.1"
+torch = "^1.5.0"
+torchvision = "^0.6.0"
+torchsummary = "^1.5.1"
[tool.poetry.dev-dependencies]
+pytest = "^5.4.2"
+coverage = {extras = ["toml"], version = "^5.1"}
+pytest-cov = "^2.9.0"
+pytest-mock = "^3.1.0"
+black = "^19.10b0"
+flake8 = "^3.8.2"
+flake8-bandit = "^2.1.2"
+flake8-black = "^0.2.0"
+flake8-bugbear = "^20.1.4"
+flake8-import-order = "^0.18.1"
+safety = "^1.9.0"
+mypy = "^0.770"
+pytype = {version = "^2020.5.13", python = "3.7"}
+typeguard = "^2.7.1"
+xdoctest = "^0.12.0"
+sphinx = "^3.0.4"
+[tool.coverage.report]
+fail_under = 50
[build-system]
requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api"