summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorGustaf Rydholm <gustaf.rydholm@gmail.com>2021-03-28 22:02:24 +0200
committerGustaf Rydholm <gustaf.rydholm@gmail.com>2021-03-28 22:02:24 +0200
commit46a1472d33d3a4180798492e819f2ec02bc3b1a3 (patch)
tree22322ed0d8f9f803966ea745ec5bb8c759f8db64 /pyproject.toml
parent8248f173132dfb7e47ec62b08e9235990c8626e3 (diff)
Add refactor of iam lines
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index a4da5b8..ffe9c68 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -15,7 +15,6 @@ click = "^7.1.2"
flake8-annotations = "^2.1.0"
flake8-docstrings = "^1.5.0"
darglint = "^1.3.1"
-desert = "^2020.1.6"
marshmallow = "^3.6.0"
sphinx-autodoc-typehints = "^1.10.3"
sphinx_rtd_theme = "^0.4.3"
@@ -31,16 +30,14 @@ pytest = "^5.4.3"
opencv-python = "^4.3.0"
nltk = "^3.5"
torch-summary = "^1.4.2"
-python-Levenshtein = "^0.12.0"
defusedxml = "^0.6.0"
-pytorch-metric-learning = "^0.9.92"
omegaconf = "^2.0.2"
-jupyterthemes = "^0.20.0"
wandb = "^0.10.12"
einops = "^0.3.0"
gtn = "^0.0.0"
sentencepiece = "^0.1.95"
pytorch-lightning = "^1.2.4"
+Pillow = "^8.1.2"
[tool.poetry.dev-dependencies]
pytest = "^5.4.2"
@@ -71,8 +68,11 @@ fail_under = 50
[tool.poetry.scripts]
download-emnist = "text_recognizer.data.emnist:download_emnist"
+download-nltk = "text_recognizer.data.sentence_generator:load_nltk_brown_corpus"
generate-emnist-lines = "text_recognizer.data.emnist_lines:generate_emnist_lines"
download-iam = "text_recognizer.data.iam:download_iam"
+generate-iam-lines = "text_recognizer.data.iam_lines:generate_iam_lines"
+
create-emnist-support-files = "text_recognizer.tests.support.create_emnist_support_files:create_emnist_support_files"
create-emnist-lines-datasets = "text_recognizer.datasets.emnist_lines_dataset:create_datasets"
create-iam-paragraphs = "text_recognizer.datasets.iam_paragraphs_dataset:main"