summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorGustaf Rydholm <gustaf.rydholm@gmail.com>2022-01-26 23:27:35 +0100
committerGustaf Rydholm <gustaf.rydholm@gmail.com>2022-01-26 23:27:35 +0100
commit7694f70ec78d748694f818ad9d10ca46c1f04a96 (patch)
tree9604a8728c636ee135713ee584e2e33ac1e8f93a /pyproject.toml
parent69e93847bb0adf6e819f48e70e6a88da4cf0b7f6 (diff)
chore: update dependencies
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml27
1 files changed, 13 insertions, 14 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 79f98e8..24d3ecb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -12,25 +12,12 @@ keywords = ["text recognizer, deep learning, pytorch"]
[tool.poetry.dependencies]
python = "^3.9"
click = "^7.1.2"
-boltons = "^20.1.0"
-h5py = "^3.2.1"
-toml = "^0.10.1"
loguru = "^0.5.0"
-matplotlib = "^3.2.1"
-tqdm = "^4.46.1"
opencv-python = "^4.3.0"
-nltk = "^3.5"
-defusedxml = "^0.6.0"
omegaconf = "^2.1.0"
einops = "^0.3.0"
-gtn = "^0.0.0"
-sentencepiece = "^0.1.95"
pytorch-lightning = "^1.5.9"
-Pillow = "^9.0.0"
-madgrad = "^1.0"
-editdistance = "^0.5.3"
-torchmetrics = "^0.4.1"
-hydra-core = "^1.1.0"
+hydra-core = "^1.1.1"
attr = "^0.3.1"
torch = "^1.10.1"
torchvision = "^0.11.2"
@@ -58,6 +45,18 @@ jupyterlab = "^3.0.15"
ipywidgets = "^7.6.3"
torchinfo = "^1.5.3"
jupyter = "^1.0.0"
+h5py = "^3.6.0"
+matplotlib = "^3.5.1"
+boltons = "^20.1.0"
+nltk = "^3.6.7"
+defusedxml = "^0.7.1"
+sentencepiece = "^0.1.96"
+Pillow = "^9.0.0"
+editdistance = "^0.5.3"
+torchmetrics = "^0.4.1"
+tqdm = "^4.46.1"
+toml = "^0.10.1"
+setuptools = "59.5.0"
[tool.coverage.report]
fail_under = 50