summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fcb7925..822fca9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -14,12 +14,13 @@ python = "^3.9"
loguru = "^0.6.0"
omegaconf = "^2.1.0"
einops = "^0.3.0"
-pytorch-lightning = "^1.6.3"
+pytorch-lightning = "^1.7.5"
hydra-core = "^1.1.1"
smart-open = "^5.2.1"
torch = "^1.11.0"
torchvision = "^0.12.0"
adan-pytorch = "^0.1.0"
+torchmetrics = "^0.9.3"
[tool.poetry.dev-dependencies]
pytest = "^5.4.2"
@@ -51,7 +52,7 @@ nltk = "^3.6.7"
defusedxml = "^0.7.1"
Pillow = "^9.0.0"
editdistance = "^0.5.3"
-torchmetrics = "^0.4.1"
+torchmetrics = "^0.9.3"
tqdm = "^4.46.1"
toml = "^0.10.1"
setuptools = "59.5.0"