summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 2 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c3f6ebc..6b5f62b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -15,12 +15,11 @@ click = "^7.1.2"
boltons = "^20.1.0"
h5py = "^3.2.1"
toml = "^0.10.1"
-torch = "^1.8.0"
+torch = "^1.8.1"
torchvision = "^0.9.0"
loguru = "^0.5.0"
matplotlib = "^3.2.1"
tqdm = "^4.46.1"
-pytest = "^5.4.3"
opencv-python = "^4.3.0"
nltk = "^3.5"
torch-summary = "^1.4.2"
@@ -29,7 +28,7 @@ omegaconf = "^2.0.2"
einops = "^0.3.0"
gtn = "^0.0.0"
sentencepiece = "^0.1.95"
-pytorch-lightning = "^1.3.1"
+pytorch-lightning = "^1.3.4"
Pillow = "^8.1.2"
madgrad = "^1.0"
editdistance = "^0.5.3"
@@ -49,10 +48,7 @@ flake8-bugbear = "^20.1.4"
flake8-import-order = "^0.18.1"
safety = "^1.9.0"
mypy = "^0.770"
-pytype = {version = "^2020.5.13", python = "3.7"}
typeguard = "^2.7.1"
-xdoctest = "^0.12.0"
-sphinx = "^3.0.4"
wandb = "^0.10.30"
scipy = "^1.6.1"
flake8-annotations = "^2.6.2"