summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml56
1 files changed, 50 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b535304..5cfc728 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -18,7 +18,6 @@ hydra-core = "^1.2.0"
smart-open = "^5.2.1"
torch = ">=2.0.0"
torchvision = "^0.15.0"
-adan-pytorch = "^0.1.0"
torchmetrics = "^0.9.3"
pytorch-lightning = "^2.0.7"
nvidia-cublas-cu11 = "^11.11.3.6"
@@ -71,6 +70,8 @@ flake8-import-order = "^0.18.1"
flake8-bandit = "^4.1.1"
darglint = "^1.8.1"
hydra-optuna-sweeper = "^1.2.0"
+lion-pytorch = "^0.1.2"
+adan-pytorch = "^0.1.0"
[tool.coverage.report]
fail_under = 50
@@ -78,10 +79,6 @@ fail_under = 50
[tool.isort]
profile = "black"
-[tool.ruff]
-line-length = 88
-select = []
-
[tool.poetry.scripts]
download-emnist = "text_recognizer.data.emnist:download_emnist"
download-nltk = "text_recognizer.data.utils.sentence_generator:load_nltk_brown_corpus"
@@ -93,5 +90,52 @@ generate-iam-synthetic-paragraphs = "text_recognizer.data.iam_synthetic_paragrap
show-iam-extended-info = "text_recognizer.data.iam_extended_paragraphs:show_dataset_info"
[build-system]
-requires = ["poetry-core>=1.0.0"]
+requires = ["poetry-core>=1.6.0"]
build-backend = "poetry.core.masonry.api"
+
+[tool.ruff]
+# Enable pycodestyle (`E`) and Pyflakes (`F`) codes by default.
+select = ["E", "F"]
+ignore = []
+
+# Allow autofix for all enabled rules (when `--fix`) is provided.
+fixable = ["A", "B", "C", "D", "E", "F", "G", "I", "N", "Q", "S", "T", "W", "ANN", "ARG", "BLE", "COM", "DJ", "DTZ", "EM", "ERA", "EXE", "FBT", "ICN", "INP", "ISC", "NPY", "PD", "PGH", "PIE", "PL", "PT", "PTH", "PYI", "RET", "RSE", "RUF", "SIM", "SLF", "TCH", "TID", "TRY", "UP", "YTT"]
+unfixable = []
+
+# Exclude a variety of commonly ignored directories.
+exclude = [
+ ".bzr",
+ ".direnv",
+ ".eggs",
+ ".git",
+ ".git-rewrite",
+ ".hg",
+ ".mypy_cache",
+ ".nox",
+ ".pants.d",
+ ".pytype",
+ ".ruff_cache",
+ ".svn",
+ ".tox",
+ ".venv",
+ "__pypackages__",
+ "_build",
+ "buck-out",
+ "build",
+ "dist",
+ "node_modules",
+ "venv",
+]
+
+# Same as Black.
+line-length = 88
+
+# Allow unused variables when underscore-prefixed.
+dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
+
+# Assume Python 3.8
+target-version = "py38"
+
+[tool.ruff.mccabe]
+# Unlike Flake8, default to a complexity level of 10.
+max-complexity = 10